Back to overview
Downtime

Middle-Zone website and server in Z location is currently unavailable

Nov 19 at 07:30pm CET
Affected services
Middle-Zone.com - Website

Resolved
Nov 20 at 09:57am CET

Middle-Zone website is running correctly.

Updated
Nov 19 at 08:05pm CET

We have resolved problem with server in Z location. On website still working. Thank you for patience!

Created
Nov 19 at 07:30pm CET

We are currently experiencing a power outage affecting our network in the Z location. Our team is in close contact with the network operator and working diligently to resolve the issues as quickly as possible.

We sincerely apologize for the inconvenience this may cause and appreciate your patience during this time. Please be assured that all affected customers will be compensated once the issue is resolved.

Unfortunately it's hard to give an ETA, but we'd like to resolve this as soon as possible.